两个Ubuntu创建桌面启动程序的方法

1、最近遇到的一个问题就是PHP开发使用PhpStorm IDE, 但是在Ubuntu下要每次在终端执行该sh文件才能打开, 虽然加了全局变量, 但还是很淡疼, 于是找到创建桌面启动程序的方法: 首先安装: sudo apt-get install --no-install-recommends gnome-panel 安装完成后,打开终端,运行下面命令: gnome-desktop-item-edit ~/ --create-new 便会在用户目录下创建一个启动图标了, 然后锁定到快速启动项就可以了。 2、在Linux下使用Eclipse, 只能在终端打开, 于是想把Eclipse添加到桌面快速启动栏, 其实启动栏都对应的是/usr/share/applications文件夹下的文件, 那我们就在这个文件夹下面创建一个Eclipse.desktop: [Desktop Entry] Name=Eclipse Comment=Eclipse IDE Exec=/opt/eclipse/eclipse Icon=/opt/eclipse/icon.xpm Terminal=false Type=Application Categories=Application;Development; 其中的Icon是你的eclipse目录下的图标位置, 保存退出后你就能在主页搜索关键字Eclipse打开进入Eclipse了, 希望能帮到你。 原文地址 http://blog.csdn.net/wh_luosangnanka5/article/details/7804728

Ubuntu如何安装切换jdk版本

在配置java jdk的时候,总是存在一些版本不兼容的问题,下面就说说如何切换jdk版本。 我系统自带的jdk是1.6执行java -version java3 1.jdk安装 首先可以使用命令直接进行jdk安装
sudo apt-get install openjdk-7-jre openjdk-7-jdk.
也可下载安装包后通命令安装
tar -zxvf jdk-7u10-linux-i586.tar.gz
2.添加jdk:
update-alternatives --install /usr/bin/java java /usr/lib/jvm/java/jdk1.7.0_10/bin/java 300
update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/java/jdk1.7.0_10/bin/javac 300
 注意:jdk1.7.0_10版本不同会有变动
3.查看相应的jdk是否在 ubuntu的jdk菜单里,查看:
sudo update-alternatives --config java
sudo update-alternatives --config javac
结果如下 java2 选择序号,回车即可; 4.然后java -version,javac -version查看当前jdk版本 java3

Ubuntu安装php即常见错误解决方法

下载PHP源码包 wget http://cn2.php.net/distributions/php-5.3.8.tar.gz
解压tar zxvf php-5.3.8.tar.gz
解压后进入php目录中,“cd php-5.3.8”回车,并执行“sudo ./configure --prefix=/usr/local/server/php --with-config-file-path=/usr/local/server/php --enable-mbstring --enable-ftp --with-gd --with-jpeg-dir=/usr --with-png-dir=/usr --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-pear --enable-sockets --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib --with-libxml-dir=/usr --with-xmlrpc --enable-zip --enable-fpm --enable-fpm --enable-xml --enable-sockets --with-gd --with-zlib --with-iconv --enable-zip --with-freetype-dir=/usr/lib/ --enable-soap --enable-pcntl --enable-cli”回车。
出现得错误如下: 错误一: configure: error: xml2-config not found. Please check your libxml2 installation. 而我已经安装过了libxml2,但是还是有这个提示: 解决办法: # sudo apt-get install libxml2-dev 错误二: configure: error: Please reinstall the BZip2 distribution 而我也已经安装了bzip2,网上找到得解决方案都是需要安装bzip2-dev,可是11.10里面没有这个库。 解决办法:在网上找到bzip2-1.0.5.tar.gz,解压,直接make ,sudo make install.(我使用的该源来自于http://ishare.iask.sina.com.cn/f/9769001.html) 错误三: configure: error: Please reinstall the libcurl distribution -easy.h should be in /include/curl/ 解决办法: # sudo apt-get install libcurl4-gnutls-dev 错误四: configure: error: jpeglib.h not found. 解决办法: # sudo apt-get install libjpeg-dev 错误五: configure: error: png.h not found. 解决办法: # sudo apt-get install libpng-dev 错误六: configure: error: libXpm.(a|so) not found. 解决办法: # sudo apt-get install libxpm-dev 错误七: configure: error: freetype.h not found. 解决办法: # sudo apt-get install libfreetype6-dev 错误八: configure: error: Your t1lib distribution is not installed correctly. Please reinstall it. 解决办法: # sudo apt-get install libt1-dev 错误九: configure: error: mcrypt.h not found. Please reinstall libmcrypt. 解决办法: # sudo apt-get install libmcrypt-dev 错误十: configure: error: Cannot find MySQL header files under yes. Note that the MySQL client library is not bundled anymore! 解决办法: # sudo apt-get install libmysql++-dev 错误十一: configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution 解决办法: # sudo apt-get install libxslt1-dev 可见PHP源码安装之前需要先安装这些依赖,详细可见http://forum.ubuntu.org.cn/viewtopic.php?f=88&t=231159 如上错误都解决之后,再次./config….没有错误之后, # make # sudo make install
等待操作完成之后,复制启动脚本。输入“sudo cp ./sapi/fpm/init.d.php-fpm /etc/init.d/php-fpm”回车,接着再执行“sudo chmod +x /etc/init.d/php-fpm”。 修改PHP-FPM配置文件,依次执行“cd /usr/local/server/php/etc”、“mv php-fpm.conf.default php-fpm.conf”、“vi php-fpm.conf”编辑配置文件。 去掉25行前的分号。 修改第131和132行的user和group为当前用户(安装系统时设置的帐户名)。 去掉161、166、171、176行前面的分号

ubuntu 安装 php5.4

首先用ubuntu现有的命令直接装lamp环境的话。受ubuntu ppa源的限制,php只能装到5.3.10版。我的程序需要5.4以上的php。 最后选定了下面的过程 第一先要把php的安装程序ppa源改成新的,分别是5.4对应 php5-oldstable  和 5.5对应php5 命令如下: 先安装ppa源扩展工具
sudo apt-get install -y ppa-purge
更新ppa源
sudo add-apt-repository ppa:ondrej/php5-oldstable

更新软件列表。
sudo apt-get update
手动安装lamp sudo apt-get install apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql phpmyadmin 上面执行完了如果版本还是 php5.3.10 再执行一下下面的代码, sudo apt-get install php5 重新升级下,就变程php5.4 了当然想装php5.5 就要吧ppa源改成
sudo add-apt-repository ppa:ondrej/php5
相信很多人在百度或谷歌搜 “ubuntu 安装php5.4的时候,会搜到安装php5.5的代码”,为什么会出现这种情况呢,原因上面说了,ppa源,一般是最新的软件,所以现在的版本是php5.5.要是不小心安装了php5.5要怎么样,才能重新安装php5.4呢? 方法如下:
add-apt-repository  ppa:ondrej/php5-oldstable
apt-get update
ppa-purge ppa:ondrej/php5
apt-get update && apt-get upgrade -y && apt-get autoremove -y && apt-get autoclean -y
apt-get install php5-fpm

ubuntu 包管理

apt-cache search # ------(package 搜索包) apt-cache show #------(package 获取包的相关信息,如说明、大小、版本等) apt-get install # ------(package 安装包) apt-get install # -----(package --reinstall 重新安装包) apt-get -f install # -----(强制安装, "-f = --fix-missing"当是修复安装吧...) apt-get remove #-----(package 删除包) apt-get remove --purge # ------(package 删除包,包括删除配置文件等) apt-get autoremove --purge # ----(package 删除包及其依赖的软件包+配置文件等(只对6.10有效,强烈推荐)) apt-get update #------更新源 apt-get upgrade #------更新已安装的包 apt-get dist-upgrade # ---------升级系统 apt-get dselect-upgrade #------使用 dselect 升级 apt-cache depends #-------(package 了解使用依赖) apt-cache rdepends # ------(package 了解某个具体的依赖,当是查看该包被哪些包依赖吧...) apt-get build-dep # ------(package 安装相关的编译环境) apt-get source #------(package 下载该包的源代码) apt-get clean && apt-get autoclean # --------清理下载文件的存档 && 只清理过时的包 apt-get check #-------检查是否有损坏的依赖 dpkg -S filename -----查找filename属于哪个软件包 apt-file search filename -----查找filename属于哪个软件包 apt-file list packagename -----列出软件包的内容 apt-file update --更新apt-file的数据库 dpkg --info "软件包名" --列出软件包解包后的包名称. dpkg -l --列出当前系统中所有的包.可以和参数less一起使用在分屏查看. (类似于rpm -qa) dpkg -l |grep -i "软件包名" --查看系统中与"软件包名"相关联的包. dpkg -s 查询已安装的包的详细信息. dpkg -L 查询系统中已安装的软件包所安装的位置. (类似于rpm -ql) dpkg -S 查询系统中某个文件属于哪个软件包. (类似于rpm -qf) dpkg -I 查询deb包的详细信息,在一个软件包下载到本地之后看看用不用安装(看一下呗). dpkg -i 手动安装软件包(这个命令并不能解决软件包之前的依赖性问题),如果在安装某一个软件包的时候遇到了软件依赖的问题,可以用apt-get -f install在解决信赖性这个问题. dpkg -r 卸载软件包.不是完全的卸载,它的配置文件还存在. dpkg -P 全部卸载(但是还是不能解决软件包的依赖性的问题) dpkg -reconfigure 重新配置 apt-get install 下载软件包,以及所有依赖的包,同时进行包的安装或升级。如果某个包被设置了 hold (停止标志,就会被搁在一边(即不会被升级)。更多 hold 细节请看下面。 apt-get remove [--purge] 移除 以及任何依赖这个包的其它包。 --purge 指明这个包应该被完全清除 (purged) ,更多信息请看 dpkg -P。 apt-get update 升级来自 Debian 镜像的包列表,如果你想安装当天的任何软件,至少每天运行一次,而且每次修改了 /etc/apt/sources.list 後,必须执行。 apt-get upgrade [-u] 升 级所有已经安装的包为最新可用版本。不会安装新的或移除老的包。如果一个包改变了依赖关系而需要安装一个新的包,那么它将不会被升级,而是标志为 hold。apt-get update 不会升级被标志为 hold 的包 (这个也就是 hold 的意思)。请看下文如何手动设置包为 hold。我建议同时使用 '-u' 选项,因为这样你就能看到哪些包将会被升级。 apt-get dist-upgrade [-u] 和 apt-get upgrade 类似,除了 dist-upgrade 会安装和移除包来满足依赖关系。因此具有一定的危险性。 apt-cache search 在软件包名称和描述中,搜索包含xxx的软件包。 apt-cache show 显示某个软件包的完整的描述。 apt-cache showpkg 显示软件包更多细节,以及和其它包的关系。 dselect console-apt aptitude gnome-apt APT 的几个图形前端(其中一些在使用前得先安装)。这里 dselect 无疑是最强大的,也是最古老,最难驾驭。 普通 Dpkg 用法 dpkg -i 安装一个 Debian 包文件,如你手动下载的文件。 dpkg -c 列出 的内容。 dpkg -I 从 中提取包信息。 dpkg -r 移除一个已安装的包。 dpkg -P 完全清除一个已安装的包。和 remove 不同的是,remove 只是删掉数据和可执行文件,purge 另外还删除所有的配制文件。 dpkg -L 列出 安装的所有文件清单。同时请看 dpkg -c 来检查一个 .deb 文件的内容。 dpkg -s 显示已安装包的信息。同时请看 apt-cache 显示 Debian 存档中的包信息,以及 dpkg -I 来显示从一个 .deb 文件中提取的包信息。 dpkg-reconfigure 重 新配制一个已经安装的包,如果它使用的是 debconf (debconf 为包安装提供了一个统一的配制界面)。你能够重新配制 debconf 它本身,如你想改变它的前端或提问的优先权。例如,重新配制 debconf,使用一个 dialog 前端,简单运行: dpkg-reconfigure --frontend=dialog debconf (如果你安装时选错了,这里可以改回来哟:) echo " hold" | dpkg --set-selections 设置 的状态为 hlod (命令行方式) dpkg --get-selections "" 取的 的当前状态 (命令行方式) 支持通配符,如: Debian:~# dpkg --get-selections *wine* libwine hold libwine-alsa hold libwine-arts hold libwine-dev hold libwine-nas hold libwine-print hold libwine-twain hold wine hold wine+ hold wine-doc hold wine-utils hold 例如: 大家现在用的都是 gaim-0.58 + QQ-plugin,为了防止 gaim 被升级,我们可以采用如下方法: 方法一: Debian:~# echo "gaim hold" | dpkg --set-selections 然後用下面命令检查一下: Debian:~# dpkg --get-selections "gaim" gaim hold 现在的状态标志是 hold,就不能被升级了。 如果想恢复怎么办呢? Debian:~# echo "gaim install" | dpkg --set-selections Debian:~# dpkg --get-selections "gaim" gaim install 这时状态标志又被重置为 install,可以继续升级了。 同志们会问,哪个这些状态标志都写在哪个文件中呢? 在 /var/lib/dpkg/status 里,你也可以通过修改这个文件实现 hold。 有时你会发现有的软件状态标志是 purge,不要奇怪。 如:事先已经安装了 amsn,然後把它卸了。 apt-get remove --purge amsn 那么状态标志就从 install 变成 purge。 方法二: 在/etc/apt 下手动建一个 preferences 文件 内容: Package: gaim Pin: version 0.58* 保存 dpkg -S 在包数据库中查找 ,并告诉你哪个包包含了这个文件。(注:查找的是事先已经安装的包) -------------------------------------------- Debian的软件包管理工具命令不完全列表 -------------------------------------------- Debian系统中所有的包信息都在/var/lib/dpkg下.其中/var/lib/dpkg/info目录中保存了各个软件包的信息及管理文件.每个文件的作用如下: 以 ".conffiles"     结尾的文件记录软件包的配置列表. 以 ".list"          结尾的文件记录了软件包的文件列表,用户可在文件当中找到软件包文件的具体安装位置. 以 ".md5sums"       结尾的文件记录了md5信息,用来进行包的验证的. 以 ".config"        结尾的文件是软件包的安装配置角本. 以 ".postinst"      角本是完成Debian包解开之后的配置工作,通常用来执行所安装软件包相关的命令和服务的重新启动. 以 ".preinst"       角本在Debain解包之前运行,主要作用是是停止作用于即将升级的软件包服务直到软件包安装或和升级完成. 以 ".prerm"         脚本负责停止与软件包关联的daemon服务,在删除软件包关联文件之前执行. 以 ".postrm"        脚本负责修改软件包链接或文件关联,或删除由它创建的文件. /var/lib/dpkg/available是软件包的描述信息. 包括当前系统中所有使用的Debian安装源中所有的软件包,还包括当前系统中已经安装和未安装的软件包. 1.dpkg包管理工具 dpkg -r 卸载软件包.不是完全的卸载,它的配置文件还存在. dpkg --info "软件包名" --列出软件包解包后的包名称. dpkg -l     --列出当前系统中所有的包.可以和参数less一起使用在分屏查看. dpkg -l |grep -i "软件包名" --查看系统中与"软件包名"相关联的包. dpkg -s   查询已安装的包的详细信息. dpkg -L   查询系统中已安装的软件包所安装的位置. dpkg -S   查询系统中某个文件属于哪个软件包. dpkg -I   查询deb包的详细信息,在一个软件包下载到本地之后看看用不用安装(看一下呗). dpkg -i 手动安装软件包(这个命令并不能解决软件包之前的依赖性问题),如果在安装某一个软件包的时候遇到了软件依赖的问题,可以用apt-get -f install在解决信赖性这个问题. dpkg -reconfigure 重新配置 dpkg -P 全部卸载(但是还是不能解决软件包的依赖性的问题) 2. apt高级包管理工具 (1)GTK图形的"synaptic",这是APT的前端工具. (2)"aptitude",这也是APT的前端工具. 用APT管理工具进行包的管理,可以有以下几种方法做源: (1)拿安装盘做源,方法如下: apt-cdrom ident        扫描光盘的信息 apt-cdrom add          添加光盘源 (2)这也是最常用的方法就是把源添加到/etc/apt/source.list中,之后更新列apt-get update APT管理工具常用命令 apt-cache 加上不同的子命令和参数的使用可以实现查找,显示软件,包信息及包信赖关系等功能. apt-cache stats 显示当前系统所有使用的Debain数据源的统计信息. apt-cache search +"包名",可以查找相关的软件包. apt-cache show   +"包名",可以显示指定软件包的详细信息. apt-cache depends +"包名",可以查找软件包的依赖关系. apt-get upgrade   更新系统中所有的包到最新版 apt-get install   安装软件包 apt-get --reindtall install 重新安装软件包 apt-get remove 卸载软件包 apt-get --purge remove 完全卸载软件包 apt-get clean 清除无用的软件包 在用命令apt-get install之前,是先将软件包下载到/var/cache/apt/archives中,之后再进行安装的.所以我们可以用apt-get clean清除/var/cache/apt/archives目录中的软件包. 源码包安装 apt-cache showsrc 查找看源码包的文件信息(在下载之前) apt-get source 下载源码包. apt-get build-dep +"包名" 构建源码包的编译环境. 清除处于rc状态的软件包 dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "] | sudo xargs dpkg -P - 按ppa安装wiz步骤 sudo add-apt-repository ppa:wiznote-team sudo apt-get update sudo apt-get install wiznote

Ubuntu中文输入法的安装 可选择谷歌输入法

Ubuntu上的输入法主要有小小输入平台(支持拼音/二笔/五笔等),Fcitx,Ibus,Scim等。其中Scim和Ibus是输入法框架。
在Ubuntu的中文系统中自带了中文输入法,通过Ctrl+Space可切换中英文输入法。这里我们主要说下Ubuntu英文系统中,中文输入法的安装。
安装输入法的第一步,是安装语言包。我们选择System Settings-->Language Support-->Install/Remove 输入密码后,系统会安装简体中文语言包。
第二步,安装IBus框架,在终端输入以下命令:
sudo apt-get install ibus ibus-clutter ibus-gtk ibus-gtk3 ibus-qt4
启动IBus框架,在终端输入:
im-switch -s ibus
安装完IBus框架后注销系统,保证更改立即生效。
第三步:安装拼音引擎
有下面几种常用选择:
IBus拼音:sudo apt-get install ibus-pinyin
IBUS五笔:sudo apt-get install ibus-table-wubi
谷歌拼音输入法:sudo apt-get install ibus-googlepinyin
Sun拼音输入法:sudo apt-get install ibus-sunpinyin
第四步:设置IBus框架  
ibus-setup
此时,IBus Preference设置被打开。我们在Input Method选项卡中,选择自己喜欢的输入方式,并配置自己喜欢 第五步:通常情况下,IBus图标(一个小键盘)会出现在桌面右上角的任务栏中。有时候这个图标会自行消失,可使用以下命令,找回消失的IBus图标:
ibus-daemon -drx